Skip to content
Service & Support

Robomow Help Center

Which operating systems does the Robomow App support?

The Robomow App supports the following operating systems:

  • Android 4.3 or higher
  • iOS 8.0 or higher

Note: For the moment Windows mobile is not supported by the Robomow App.