Can I have a GSM module on my robot?

Based on your Robomow model and configuration year, a GSM module may be compatible with your mower as long as your software version meets the criteria as listed below.

For RC Models

Configuration Year Software Version
2014 1.70 and higher
2015 1.70 and higher
2016 1.70 and higher

For RS Models

Configuration Year Software Version
2013 Not Available
2014 2.70 and higher
2015 2.70 and higher
2016 2.70 and higher