Skip to content
Service & Support

Robomow Help Center

Troubleshooting FAQs

Base Station Head light does not operate or is dead / No light at all

Step 1 – Make sure the Power Supply is connected well and that there is power in the wall outlet. If Yes – Proceed to Step 2. If No – It seems there is no power in the socket. Step […]

Read more »

Front Wheel Problem Message

Step 1 – Was the mower found stuck mid-yard and the front wheel dropped down into a ditch, hole in the ground, or front of the mower sitting raised up on a tree root making the front wheel drop down? […]

Read more »

Mower Does Not Start Automatic Mowing

Step 1 – Press the up-arrow button (3 seconds) on the mower while it is in the base station to receive a code which is the reason the mower didn’t go out to automatic operation. Code Automatic Departure Disabled Reason […]

Read more »

Base Station light blinking alternates between red and green

Step 1 – Make sure the Power Supply is connected well and that there is power in the wall outlet. If Yes – Proceed to Step 2. If No – It seems there is no power in the socket. Connect […]

Read more »

Start Inside Message

Step 1 – Basically, the mower “thinks” it isn’t inside the installed wire area. This indicates something is wrong with the wire, the base station, power supply or mower front board, main board and wire harness between these boards. Is […]

Read more »

Unresponsive buttons on LCD panel

If you experience unresponsive buttons on your Robomow mower’s LCD panel, please follow the steps as outlined below: Test the buttons operation through Mower’s Service Menu ⇢ 897 ⇢ Tests ⇢ Buttons. Enter the buttons menu item. You should see […]

Read more »

Short Run Time (RS Models)

From docking, when sending mower to edge, or to mow a sub zone, mower starts mowing in main zone. May mow for a very short period: 10ft-50ft (3-15m)) then stop with “Time Completed” message. Out of the base station, mower […]

Read more »

Slippage Message

Issue: The mower has odometer (magnet and sensor) in the front wheel and odometers in the drive motors, and both odometers are compared to one another constantly. A simple case of mower getting stuck physically in the yard with its […]

Read more »

Rain Sensor is not working

This message will display after the mower had attempted docking a few times unsuccessfully. Step 1 – Go to Service ⇢ 897 ⇢ Information ⇢ Special Display ⇢ Rain Sensor When dry, it should read 27 or so and when […]

Read more »

Sent to Edge or a Zone but Goes to Mow – Strange behavior

Problem: From base station, when sending mower to edge, or to mow a sub zone, your mower begins mowing in main zone instead. It may mow for a short period for about 10 to 50 feet (3 to 15m) and […]

Read more »